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Introduction
EEG toolboxes, EEG origins, rythms, headsets



Free EEG processing toolboxes

•MATLAB
•EEGLab: https://sccn.ucsd.edu/eeglab/index.php

•Brainstorm: https://neuroimage.usc.edu/brainstorm/Introduction

•Fieldtrip: https://www.fieldtriptoolbox.org/

•Python
•MNE toolbox: https://mne.tools/stable/index.html



EEG origins

•large cortical pyramidal neurons in deep 
cortical layers play a major role in the 
generation of the EEG

•postsynaptic potentials along the apical 
dendrites(perpendicular to the cortical 
surface) become electrical dipoles

Siuly, S., Li, Y., & Zhang, Y. (2016). Electroencephalogram (EEG) and 
Its Background. InEEG Signal Analysis and Classification (pp. 3-21). 
Springer, Cham.



EEG rhythms

Vaid, et al 2015



EEG headsets

Laboratory setups Portable EEG devices

64 channels19 channels EMOTIV headsetwith 14 channels

https://www.biopac.com/product/b-alert-
wireless-eeg-system-9-ch/



A Comparison of 
Electroencephalography Signals
Acquired from Conventional and 
Mobile Systems

Rieset al, 2014

2 portable, 1 laboratorysystem

Artefacts

Signal to noise ratio based on 
pre/poststimulusamplitude

Classification accuracy of single trials 
in an oddball task



Check the placement of 
EEG electrodes in EEGLab
•Spherical and MNI coordinates are available
•MNI for source localization

•In GUI: Edit > Channel locations
•In Command window: >>pop_chanedit([]);
•αtopoplot.mέ ŦǳƴŎǘƛƻƴ Ǉƭƻǘsthe electrode 

montage on scalp

•Sample data in EEGLab/sample locs
•Cartesian, spherical, polar coordinates were 

applied



Preprocessing EEG



EEG data structure

•Basic elements:
•Amplitudevalues(2/3D matrix; 

channels* time points* epochs)
•Channellabels
•Samplingfrequency
•Reference

•Advanced elements:
•Filename
•Channelcoordinates
•Badchannels
•Badepochs
•ICA weights
•History

EEGLAB struct



Continuous recordings versus event-related setup

Event-related case: series of stimuli are sent to 
the subject and we have the corresponding 
triggers marked in the recordings

SleepEEG

Resting stateEEG

Epileptic
interictal
EEG



EEG Artefacts

Motamedi-Fakhr, Shayan, et al. "Signal processing techniques applied to human 
sleep EEG signalsτA review."Biomedical Signal Processing and Control 10 (2014): 
21-33.

Manual and automatic artefactfilters areavaiable



Minguillonet al, 2017



AddingFasterto EEGLab:

Download: https://sourceforge.net/projects/faster/

UnzipFasterto EEGLab>Plugins>Fasterfolder

RunEEGLab

Tools>FASTER

https://sourceforge.net/projects/faster/


1) Interpolate bad channels globally
- Offline
- Parameters:

- Amplitude variance
- Correlation between electrodes: fit a 2nd order curve based on 

the distance
- Hurst exponent: measure the long range dependence within a 

signals (i.e.:trends). Relatedto autocorrelation



2) Remove bad epochs
- Online
- Parameters:

- Mean amplitude range across channels: for movement artefact
- Meanamplitude variance across channels: : for movement artefact
- Mean channel deviation across channels: for shifting channels



3) Substract independent components (ICs)
- Online
- IC weights computed offline (~3 min recordings required for 62 channels)
- Eye Channels required! (Fp1, Fp2 applied now)
- Parameters:



Indipendent component
analysis (ICA) in EEGLab
•Indipendentcomponentanalysisproducesthe 

maximally temporally independent signals 
available in the channel data. These are, in 
effect, information sources in the data whose 
mixtures, via volume conduction, have been 
recorded at the scalp channels.
•In EEGLab:
•1) CalculateIC weights:Tools>Decomposedataby

ICA
•2) View&removecomponents: Tools>Adjust

•Video tutorial: 
https://www.youtube.com/watch?v=JOvhHSEt-
ZU&ab_channel=mathetal



3) Substract independent components (ICs)
- Online
- IC weights computed offline (~3 min recordings required for 62 channels)
- Eye Channels required! (Fp1, Fp2 applied now)
- Parameters:

- Correlation with EOG chans
- Spatial kurtosis: for singlechanneleffects
- Slope in filter band: slopeof the spectrumfor eliminatingwhite noise
- Hurst exponent
- Median gradient: if the IC havehighfrequencyactivity



4) Interpolate bad channels within epochs
- Online
- Parameters:

- Variance
- Mean gradient
- Amplitude range
- Channel deviation



Downsample,filtering, re-referencing

•Downsample(smaller datasets, question of highest 
frequencyof interest)
•EEGLAB: Tools > Change sampling rate

•Filtering
•Filtering the continuous data minimizes the introduction 

of filtering artefacts at epoch boundaries.
•EEGLAB: Tools > Filter the data > Basic FIR filter (new, 

default)
•No phase distortion

•Re-referencing
•Common/fixed reference: tip of the nose, mastoid, etc
•Average reference: eliminate the error caused by the 

noise of the reference
•Tools > Re-reference the data



Basic features



ERP averages and plots

•EEGLab:
•pop_timtopo( EEGstruct, latency);

•GUI: Plot>ChannelERP> With scalpmaps

•GUI: Plot>ChannelERP> In scalp/ rect. array



Power spectrum

•Describes the distribution of 
power into frequency 
components composing that 
signal.
•Absolute power:
•integral of all of the power 

values within its frequency 
range

•Relative power: 
•Express the power in a 

frequency band as a percentage 
of the total power
•Correction for absolute 

differences among the subjects 
in EEG

In EEGLab:
Plot>Channelspectramaps



Some advanced features



Time-frequency analysis

•Time/frequency analysis characterizes 
changes or perturbations in the spectral 
content of the data considered as a sum 
of windowed sinusoidal functions (i.e. 
sinusoidal wavelets).
•Accuratetime and frequency resolution
•Fortrialswith triggers:
•ERSP (event-relatedspectralperturbation): 

measures average dynamic changes in 
amplitude of the broad band EEG frequency 
spectrum as a function of time relative to an 
experimental event.
•ITC (inter-trial coherence): indicates that the 

EEG activity at a given time and frequency in 
single trials becomes phase-locked

EEGLAB: 
Plot > Time frequency transforms > Channel 
time-frequency



Phase amplitude coupling (PAC)

Biologicalrelevance:
- The current view is that PAC facilitates effective 

interactions between neurons with similar 
phase preferences. 

- Memoryprocessing
- E.g.: tƘŀǎŜπŀƳǇƭƛǘǳŘŜ ŎƻǳǇƭƛƴƎ ƻŦ ǎƭŜŜǇ ǎƭƻǿ 

oscillatory and spindle activity correlates with 
overnight memory consolidation

Meanvectorlength:
- phase of slow; the amplitude of fast rhythm
- length of the complex vector: each 

instantaneous fast oscillation amplitude 
component in time 

- vector angle: slow oscillation phase of the 
same time point is represented by the

- PAC= meanvectorlength
Code: 
https://neuroimage.usc.edu/brainstorm/Tutorials/
TutPac



Functional networks in the brain

•Nodesand edges
•Nodes: recording sites or brain areas(e.g.: sourceEEG, fMRI)

•Edges: relationbetweenbrainareas (structuralor functional)

codes_: https://sites.google.com/site/bctnet/measures/list



Functional connectivity methods

•Functional connectivity (non-directed):
•Correlation
•Phase lag index (PLI):

•asymmetry of the sign of the phase difference

•Effective connectivity (directed):
•Linear (Granger-causality): 

•basedon autoregression, 
•if a signalX1 "Granger-causes" (or "G-causes") a 

signalX2, then past values ofX1 should contain 
information that helps predictX2 above and beyond the 
information contained in past values ofX2 alone.

•Nonlinear (e.g.: Transfer entropy): 
•measures the increased predictability of Y signal caused 

by an additional X signal as the difference between the 
Shannon Entropy of Y conditioned on its own past 
values and the Shannon Entropy of Y conditioned its 
ƻǿƴ ŀƴŘ · ǎƛƎƴŀƭΩǎ Ǉŀǎǘ

Codes/help:https://neuroimage.usc.edu/brainstorm/Tutorials/Connectivity



Local network parameters

•Express the role of the individual node

•Comparisons can be made between nodes, or
states/conditions/groups

Examples(centralitymeasures):

•Node strength: sum of weights of links connected 
to the node

•Betweenesscentrality: the fraction of all shortest 
paths in the network that contain a given node

•Local connectedness: sum of weights of links in 
the neighbouring nodes

•Modular hubs: strong connections within a 
module



Global network organizations

Clusteringcoefficient: >1

Averagepath length: ~1

Communitystructure
nonoverlapping(Overlapping)

Denselyconnectedsubnetworks

-Express the state of the 
whole brain network
-Comparisons can be made 
between 
states/conditions/groups



Global network organizations

Clusteringcoefficient: >1

Averagepath length: ~1

Communitystructure
nonoverlapping(Overlapping)

Denselyconnectedsubnetworks HEALTHY BRAIN



EEG in practice



EEG in practice

•Medicalapplication:
•Epilepsy (diagnosis, seizureprediction, focus localization,…)

•Brain tumor

•Brain damage from head injury

•Brain dysfunction that can have a variety of causes (encephalopathy)

•Inflammation of the brain (encephalitis)

•Stroke

•Sleep disorders

•Brain computer interface (non-invasive[EEG], invasive[ECoG] )



Applications of BCI

•replacefunctions
•α[ƻŎƪŜŘ-in syndromeέ(e.g.: Amyotrophic 

lateral sclerosis, Brainstem (pons) stroke)

•restorefunctions:
•stroke rehabilitation 

•improvefunctions: 
•Memoryimprovement using wearable EEG 

headset by identifingpoorly or well-memorized 
words from parito-occipitalpower

Prof György Karmos 



EEG-BCI

Vaidet al 2015

DRAWBACKS:

•poor spatial resolution

•low signal-to-noise ratio (any 
evoked response which gets 
embedded within on-going 
background activity)

ADVANTAGES:

•excellent
temporal resolution of less than a 
millisecond 

•portable devices available 

•Low cost

Artefacts
rejection, 
filtering, etc

Temporal, 
spectral, spatial
features



1) Slow cortical potentials (SCP)

•low frequency potentials (e.g., less 
than 1 Hz) recorded from the scalp

•Patients are trained to modify SCPs 
based on feedback and use this 
paradigm for BCI-based 
communication (Prof. Niels Birbaumer, 
Thought Translation Device).

Prof György Karmos 



2) Sensorimotor rhythms (SMR) paradigms

Overview

•Defined as the imagination of movements of large body parts 

•causes event-related desynchronization (ERD) in mu (8ς12 Hz) and beta 
rhythms (18ς26 Hz) in the contralateral central electrodes (motor cortex)

•Require training (weeks, months)

Analysis and classification methods

•SVM outperforms the other classifiers in SMR features classification

•time-frequency features couldbetter depict the non-stationary nature of 
EEG SMR

Applications

•one-dimensional computer cursor movement

•Open and close a prosthetic hand with imagined right or left-hand
movement. 

•restore hand grasp in a patient with tetraplegia 

•control objects such as quadcopters 

RIGHT

LEFT

Abiri et al 2019



BCI – based on the activity of motor cortex
(invasive)

Prof György Karmos 



3) Imagined body kinematics paradigms

Overview

•low-frequency components of EEG signals (<2 Hz) located over motor cortexcarry kinematic information 

•subject is asked to imagine the continuous movement of only one body part in multi-dimensional space 

Analysis and classification methods

•wrist rotation and extensionat fast and slow speeds.
•EEG signals were low-pass filtered at 2 Hz and the negative slope 2 s before the movementonset known as 

Bereitschaftspotential(BP).
•BP has two parts, the NS1 (Negative Slope of early BP)and the NS2 (steeper Negative Slope of late BP). The NS1,NS2, and 

the mu (8ς12 Hz) and beta rhythms (18ς26 Hz)constituted the feature space in their study 

•By comparing the decoding performance
with and without EOG contaminated brain signals, they found
that eye movement plays a significant role in IBK tasks 

Applications

•poor decoding of EEG signals 

•can be operated with zero-training 

Abiri et al 2019



4) Visual P300 paradigms

Overview

• P300 component is elicited in response to infrequently presented events using what is ƪƴƻǿƴ ŀǎ ŀƴ ΨƻŘŘōŀƭƭ ǇŀǊŀŘƛƎƳΩ 

• Advantege:

• subjects can use it with very high accuracy and it can be calibrated in minutes 

• Disadvanteges: 

• fatigue from the high level of attention and visual focus

• inability for people with visual impairments to use the system 

Analysis and classification methods

• Farwell and DonchinP300 speller

• speed/accuracy trade-off: presenting multiple trials and averagingthe EEG response is required to increase the signal-to-noiseratio

• extract an analog control signal with a single-trial approach using a genetic algorithm 

• adding occipitalelectrode locations to the p300 speller(centralmidline) significantlyimprovedthe discriminability of data samples 

• language model to enhancetyping speed was utilized 

Applications

• keyboards to provide a pathway of communication for disabled patients 

• navigate a wheelchair 

• his paradigm was also employed to control a computercursor in 2D space by paralyzed patients. 

Abiri et al 2019



P300 BCI

Prof Karmos György 



5) Steady state visual evoked potential 
paradigms
Overview

• shift gaze and as well as their attention to flickering stimuli, which requires 
highly accurate eye control 

• strong correlation between flicker frequencyand the observed frequency of 
the EEGin visualareas

• no-trainingparadigm that can be used by many subjects 

• flickering stimuli could lead to fatigue for the subject,mainly when using low 
flickering frequency (high-frequencyflicker (60ς100 Hz) is preferred)

Analysis and classification methods

• SSVEP is less vulnerable to artifacts -> mobile applicationscanbe developed

• Fastinformationtransferrate: P300 or SMR paradigms reach 4ς60 bits Ƴƛƴҍ1
informationtransfer, SSVEP-based BCIs yield 100 ōƛǘǎ Ƴƛƴҍ1

• determination of user-specific optimal stimulation duration andphase interval

Application

• control a humanoid robot 

• exoskeleton could beaccurately controlled

• used to allow a cockroach to navigate the desired path

• navigate in a two-dimensional BCI game 
Prof György Karmos 

Abiri et al 2019



6) Error-related potential (ErrP)

•ErrPoccurs when there is a mismatch 
between a ǎǳōƧŜŎǘΩǎintention to perform a 
given task and the response provided by
the BCI.

•frontal and central lobes and has a latency 
of 200ς700ms 

•The ErrPcan be used to adjust the input
control signals to the device 

•Problems:
•In contrast to a traditional control system, in 

which error signal can be sensed in 
milliseconds, the brain does not produce an 
ErrPuntil 200 msς700ms after the subject 
receivesfeedback: makes real-time 
implementation difficult. 
•ErrPdoes not contain any informationabout 

direction or magnitude 

Abiri et al 2019



Cybathlon –
Bionic Olimpics

Bularkaet al, 2016



Traditional localization of the seizure onset
zone
•occurrence of unprovokedseizures and affects ~1% of 
ǘƘŜ ǿƻǊƭŘΩǎ ǇƻǇǳƭŀǘƛƻƴ 

•approximately one-third of people with epilepsy 
continue to have seizures despitetaking medications 

•in such cases,one treatment option is surgical resection 
of the brain tissueresponsible for seizures 

•depends critically on accurate localization of the 
pathological brain tissue, whichis referred to as the 
seizure onset zone (SOZ)

•SOZlocalization requires implanting of electrodes for 
intracranialEEG (iEEG) that is recorded over several days 
to allow suffcienttime for spontaneous seizures to occur 

•Problemwith seizureinitialization:
• Long (severaldays) monitoring
• Lownumberof seizures
•Heterogenousseizureinitialization

seizureSeizureonset



Interictal electrophysiological biomarkers of 
epilepsy
Univariatebiomarkers(on singlechannels)

•HFOs(high-frequencyoscillations)

•interictal epileptiformdischarges(IEDs) 

•PAC (Phase-amplitudecoupling) 

•CFC (Cross-frequencycoupling)

Bivariatebiomarkers(on multiple channels)

•Functional/effectiveconnectivity

•Network parameters



1) Integrating artificial intelligence with real-time 
intracranial EEG monitoring to automate interictal
identification of seizure onset zones in focal epilepsy

Univariatebiomarkers(on single
channels)
•HFOs(high-frequencyoscillations)
•neurons firing asynchronously
•>80Hz, EEG needs to be sampled at 

least at 2kHz

•interictalepileptiformdischarges
(IEDs) 
•diverse ligand-gated mechanisms 

activate IEDs and lead to network 
hyperexcitability

•PAC (Phase-amplitudecoupling) 
Yogatheesan
Varatharajahet 
al 2018
Zijlmanset al, 
2012 

a Interictalspike; b groupof interictal spikesfrom neocorticaldysplasia, c sharp
wavefrom a lesionalpartial epilepsy; d fastactivity (brushes) ridingon a spike
recordedfrom a Taylor type II focalcorticaldysplasia; e paroxysmalslowactivity
superimposedto slowspikesrecordedin a lesionalpartial epilepsy.

Curtis et 
al, 2012



Detection of HFOs, PAC, IEDs

•HFO (Cimbalniket al 2016):
•Oscillations that have an amplitude of three standard deviations 

above the mean and lasting for
more than one complete cycle in low-gamma (30ς60 Hz), high-
gamma (60ς100 Hz), and ripple (100ς150 Hz) bands are 
detected. 

•PAC (Canolty, et al, 2006): 
•correlating instantaneous phase of the low-frequency signal with

the corresponding amplitude of a highfrequency signal 
•0.1ς30 Hz was chosen as the low-frequency (modulating) 
•65ς115 Hz was chosen as the high-frequency

(modulated) 
•The specific phase of LowFrequencyOscillationmodulates and 

promotes the amplitude of HFOs in tune surge ,and strengthen 
the synchronization of HFOs.

•IED (Barkmeieret al 2012 ):
•Spikedetectionalgorithm
•4.times SD of the baseline



K=2, largeravg
biomarkerrate
consideredas
abnormal

Clusteringof 
eachbiomarker
doneseparetely

36D featurevector



-accuracy of approximately 70% on82 patients, using 
interictal iEEG
-recordings durations less than 2 h is enoughfor localization
-combinationof multiple parametersresultsin a better
performance



2) Interictal localization in iEEG recordings
applying functional connectivity parameters

Functionalnetwork

ECoG
Graphparameterson
functionalnetwork



Effective graph parameters for localizing EZ 
in interictal iEEG recordings

First author

/year of

publication

Number of

patients

Applied

functional

connectivity

method

Graph

parameters

connected to the

EZ

Journal

published

Schevon, 2007 8 Phasecoherency Local

synchronization

NeuroImage

Ortega, 2008 5 correlation BC (MST) Neurosci. Lett.,

Wilke, 2010 11 DTF Strength Epilepsia

Wilke, 2011 25 DTF BC Epilepsia

Yung, 2011 16 DTF Outflow

strength

Seizure

Varotto, 2012 10 PDC Outflow

strength, BC

NeuroImage

Palmigiano,

2012

20 correlation Stability of the

local

synchronization

PLoSONE

Mierlo, 2012 8 swADTF Outflow

strength

Epilepsia

Kim, 2014 4 PLV BC BrainDev.

Consequences:

1.) Hub measurements
- nodalstrength
- BC

2.) Local connections
- local synchronization

3.) Directionality of the connectivity
-outflow 



1 2

3 4

5 6Unsuccessful
surgery

Epileptic zone

•6 presurgery
patients
•1 unsuccessful 

surgery

•Available 
recordings:
•Interictal

•FOIs: 
•gamma (30-45 Hz)

•Epoching: 
•2 s epochs

Ictal/Intracranial EEG for epileptic patients



Phase lag index

Electrode i

Histogram of the 

phase difference

Electrode j
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Epileptic changes in the small-world
configuration in higher frequency bands

Global network changes Local network changes

Lossof long-
range

connections

Strengthen the
local 

connections

Interictalςsmallworld

Ictalςorded
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- The epilepticnetworkmayhas highlocal 
modularhubsin the epilepticzone:

- Highwithin moduledegree
- Lowbetweenmodul connectivity

*

=

Intreictal/ Ictal iEEG: Ponten, 2007



Local modular hubs (interictal, gamma band)

Unsuccessful surgery



3) Interictal localization in foramen ovale recordings
applying functional connectivity parameters

•12 patientswithunilateral(7 left, 5 right)mesial
temporallobeepilepsy

•5separate, 60 secondslong, interictalEEG and 
FO recordings
for each patientduring sleep

•Filtered togamma band(30-45 Hz), segmentedto
0.5 sec epochs

•Phaselagindex wascalculatedbetweenelectrode
contactsonthesameside

•PLI(affectedside)-PLI(healthyside) predictsthe
epilepticfocus
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